Home > Linux > NVIDIA 304.60 and OpenSUSE 11.4

NVIDIA 304.60 and OpenSUSE 11.4

NVIDIA recently released their 304.60 drivers to the main OpenSUSE repo. Sadly, these drivers didn’t have a proper dependency for the kernel-desktop-devel in them, which broke the install and caused the machine to fail on bootup – failsafe mode worked however.

I submitted a bug report to NVIDIA and to be fair Daniel Dadap got back to me very quickly – but I had already solved the issue. The steps are;

  1. Reinstall kernel-devel and reboot
  2. Reinstall the nvidia kernel module ( nvidia-gfxG02-kmp-desktop ) and nvidia-computeG02
  3. Reinstall x11-video-nvidiaG02
  4. Reboot*

The system should now boot back up normally.

The email from NVIDIA was;

Hi Nick,

The 304.60 RPMs for the NVIDIA kernel driver are prepared differently
from previous NVIDIA kernel driver RPMs. It seems that, for the
nvidia-gfxG02-kmp-desktop package, the kernel-desktop-devel package was
not declared as a dependency, which could lead to a failure to install
the kernel driver.

With a failed 304.60 kernel driver installation, and a successful
installation of the 304.60 userspace components, it's expected to see
messages like the one you reported. If this is indeed the cause of your
problem, you should be able to install the driver by first installing
the kernel-desktop-devel package manually, then attempting to reinstall
the 304.60 RPM.

Sorry for any inconvenience this may have caused.

 

* You can get away with the following, if you don’t want to reboot so often.

one reboot after kernel update, install nvidia module, init 3, rmmod nvidia, modprobe nvidia, init 5

  • Unrelated, but there’s an issue installing Bumblebee in Ubuntu 12.10 whereby bbswitch-dkms doesn’t install into the headers of whatever kernel you’re on. Solution is:

    apt-get purge bumblebee bbswitch-dkms
    reboot
    apt-get install linux-headers-3.5.0-***-generic
    reboot
    apt-get install bumblebee bbswitch-dkms
    reboot

TOP